Accessibility Skip to content

HDX - Multiple Web UI Vulnerabilities

Vulnerability Summary

Four security vulnerabilities in HDX Series products have been fixed in release 3.1.14.

  1. CVE-2019-11355: The CSR generation tool is subject to Remote Code Execution. Administrators logged in to the web UI can abuse this to attain privileged access to the operating system.

  2. A stored XSS defect in the closed caption utility allows anyone who can login to the HDX web UI to potentially run malicious javascript on other web UI clients who view the closed caption output.

  3. The deployed embedded web server in Polycom HDX systems allows HTTP Verb Tampering. The server fails to validate the HTTP requests to specific verbs. It is possible to disclose system information by tampering the HTTP verb (e.g. changing HTTP POST to HTTP GET).

  4. The Remote Access component fails to validate input passed by a user of the web UI and is thus vulnerable to XSS exploitation that can execute javascript payloads in the context of the user.

 

Details

CVE 2019-11355 

An issue was discovered in Poly (formerly Polycom) HDX 3.1.13. A feature exists that allows the creation of a server / client certificate, or the upload of the user certificate, on the administrator's page. The value received from the user is the factor value of a shell script on the equipment. By entering a special character (such as a single quote) in a CN or other CSR field, one can insert a command into a factor value. A system command can be executed as root.

Poly released a firmware update to address this vulnerability.  There is no workaround.

Published

Last Update: 3/7/2022
Initial Public Release: 4/26/2019
Advisory ID:  PLYTV19-03

CVE ID: CVE-2019-11355
CVSS Score: 7.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Product Affected
PRODUCTS FIRMWARE FIX
HDX 4000 Prior to 3.1.14 3.1.14 and above
HDX 6000

Prior to 3.1.14

3.1.14 and above
HDX 7000

Prior to 3.1.14

3.1.14 and above
HDX 8000

Prior to 3.1.14

3.1.14 and above
HDX 9000

Prior to 3.1.14

3.1.14 and above
Solution

Poly recommends customers upgrade to firmware build 3.1.14 or later. 

 

Workaround

There is no workaround.

Contact

Any customer using an affected system who is concerned about this vulnerability within their deployment should contact Poly Technical Support(888) 248-4143, (916) 928-7561, or visit the Poly Support Site.

 

RECOGNITION

Poly would like to thank WootCloud and Hyunjin Ko for reporting security vulnerabilities to us and for their coordinated disclosure.

Revision History
VERSION DATE DESCRIPTION
1.0 4/26/2019 Initial Release
2.0 3/7/2022 Format Changes

©2022 Plantronics, Inc. All rights reserved.

Trademarks
Poly, the propeller design, and the Poly logo are trademarks of Plantronics, Inc.  All other trademarks are property of their respective owners. No portion hereof may be reproduced or transmitted in any form or by any means, for any purpose other than the recipient's personal use, without the express written permission of Poly.

Disclaimer
While Poly uses reasonable efforts to include accurate and up-to-date information in this document, Poly makes no warranties or representations as to its accuracy. Poly assumes no liability or responsibility for any typographical errors, out of date information, or any errors or omissions in the content of this document. Poly reserves the right to change or update this document at any time. Individuals are solely responsible for verifying that they have and are using the most recent Technical Bulletin. 

Limitation of Liability
Poly and/or its respective suppliers make no representations about the suitability of the information contained in this document for any purpose. Information is provided "as is" without warranty of any kind and is subject to change without notice. The entire risk arising out of its use remains with the recipient. In no event shall Poly and/or its respective suppliers be liable for any direct, consequential, incidental, special, punitive, or other damages whatsoever (including without limitation, damages for loss of business profits, business interruption, or loss of business information), even if Poly has been advised of the possibility of such damages.