Accessibility Skip to content
Article ID: 000032863
Last Modified Date: 10/12/2021
Access Level: Public

VVX x50 Software Stream Conversion Guide (UCS to OBi Edition)

Congratulations on owning Poly’s most flexible and powerful IP phone. This article will walk you through the steps on how to determine what software stream your VVX desktop phone is running and how to upgrade it to the software your service provider requires to run your voice service. This guide is intended for Google Voice customers with G Suite accounts only.  Converting a VVX X50 model phone to OBi Edition Software is not supported outside of G Suite environments. The VVX x50 supports two different software streams: Polycom UC Software and Polycom OBi Edition Software.
When you power up your VVX desktop phone for the first time, you might be on a software stream that your
provider does not support. Don’t worry, the VVX x50 desktop phone is flexible enough to run either stream.
 
To determine what software stream your VVX desktop phone is running lookup the version number. Your phone settings will display its Software Version – pay attention to the software naming structure:
 
Software Stream Version Naming Structure Factory Software Version
(as of March 31, 2019)
Polycom UC Software x.x.x.xxxxx 5.8.0.13851
Polycom OBi Edition Software x.x.x.x 6.3.1.0
Steps to determine software version:
Software Stream Steps to determine Software Version
Polycom UC Software
1. Press Home key
2. Go to Settings -> Status -> Platform -> Application -> Main
3. Look under “Version”
Polycom OBi Edition Software
1. Press Home key
2. Go to Product Info
3. Scroll down using Navigation key to “Software Version”
 
 

Converting Software Streams

UC Software to OBi Edition Software

When you identified that your VVX x50 desktop phone runs the Polycom UC Software and you need it to have it run OBi Edition Software, you can follow these steps below:
  1. Power-up the phone and have it connected to the internet.
  2. Determine the IP Address of your phone by hold-pressing 1, 4 and 7 simultaneously, or go to Settings > Status > Network > TCP/IP Parameters by pressing the Menu Button.
  3. Use the IP address to access the local web page of the phone. (Default password is 456 and use HTTPS).
  4. Head over to Utilities \ Software Upgrade page and select Custom Server for the Server Type
    :
  5.  
  6. Paste your upgrade server URL on the “Custom server address” field. For OBiTALK-hosted firmware files, please refer to the URLs below:
    Version 6.3.1.0: https://www.obitalk.com/VVX-OE/6.3.1.0/release.xml
    Version 6.3.1.1: https://www.obitalk.com/VVX-OE/6.3.1.1/release.xml
  7. Click “Check for Updates.” And Click on Install
    Note: Disregard the version check

OBi Edition Software to UC Software

When you identified that your VVX x50 desktop phone runs the Polycom OBi Edition Software and you need it to have it run UC Software, you can follow these steps below:
  1. Power-up the phone and have it connected to the internet.
  2. Determine the IP Address of your phone by going to Main Menu > Settings > Network
    or
    Main Menu > Product Info > IP Address 
  3. Use the IP address to access the local web page of the phone. (Default username and password is admin and admin, respectively).
  4. Browse to System Management > Auto Provisioning > Auto Firmware Update and set these parameters:



    Ensure you download the Split version of the UC Firmware to a local PC running a HTTP or FTP server and the name of the file  depends on the model number aka:

    VVX150 3111-48810-001.sip.ld
    VVX250 3111-48820-001.sip.ld
    VVX350 3111-48830-001.sip.ld
    VVX450 3111-48840-001.sip.ld

Note: If OBi version is 6.3.1 or later the background firmware upgrade is enabled by default. That means the OBi software cannot accept sip.ld firmware file format (only .fw) and so the OBi to UCS conversion cannot work unless you disable the background firmware upgrade. To do so you have to append the string ,bgu-conv=disable.  i.e. FirmwareURL = http://downloads.polycom.com/voice/software/UC_Software_5_9_4_release_sig_split/3111-48820-001.sip.ld ,bgu-conv=disable