Accessibility Skip to content

Poly UC Software: Important Notices

 

For complete information on the most recent Poly UC Software release, see Latest Poly UC Software Release. If you want to use previous software releases with your Poly phones, use the Poly UC Software/Poly SIP Software Release Matrix to find out which software versions are compatible with your phones. For all other previously released Poly UC Software versions, consult the Previous VoIP Software archive.

If you are currently using a version of software earlier than UC Software 3.3.0 and are considering an upgrade to a more recent UC Software version, be aware that enhancements to more recent software releases may not be backward compatible. Before downloading and installing more recent software, Poly strongly recommends that you read about changes to recent software versions in the Poly UC Software 3.3.0 Administrators’ Guide.

Poly follows industry standard practices regarding support of software for discontinued End of Life (EOL) products. Poly supports software for the most current version and one previous major version OR two years after the release – whichever comes first. For reference, see the Poly End of Life (EOL) Support Policy.

 

Upgrading and Downgrading to UC Software 4.x.x and 5.0.x

As of UC Software 4.x.x and 5.0.x, Poly has improved the process of upgrading and downgrading software on the phones. For detailed instructions on upgrading and downgrading your phones running UC Software 3.x.x to 4.1.x, see Engineering Advisory 64731: Poly UC Software 4.0.x: Upgrade and Downgrade Methods..

Use of Poly UC Software versions 4.1.x and later in Microsoft Lync environments requires you to purchase a software license for each device in your deployment. You must purchase the licenses from the same company you purchased your Poly phones from. Note that you can operate Poly phones with Lync Server for trial purposes for up to 30 days without purchasing a license. Use of the software is subject to the terms and conditions of the End User License Agreement. Poly reserves the right to audit your deployment to verify that you have a license for each phone.

 

Upgrade Notice for UC Software 4.0

Upgrade Notice for UC Software 4.0: If you are updating to UC Software 4.0 or later, you need to update to UC Software 4.0.x using the Poly Upgrader 4.4.0B Utility. Before you download and install Poly UC Software version 4.0.0 or higher, Poly strongly recommends that you review changes to the upgrade procedures detailed in the Poly UC Software 4.0.0 Administrators’ Guide and in Poly UC Software 4.0.x Upgrade and Downgrade Methods (Engineering Advisory 64731).

Upgrade Notice for UC Software 3.3.0:: If you use software released prior to Poly UC Software version 3.3.0 and want to use VVX 500 phones in your organization, you must update your existing configuration files as shown in Simplified Configuration Improvements in Poly UC Software 3.3.0 (Technical Bulletin 60519).

Support for Older Poly Products: For information and access to all software releases, and to match your phone model with a UC Software version, refer to the Poly UC Software/Poly SIP Software Release Matrix.

If you are currently using a version of software earlier than UC Software 3.3.0 and want to upgrade to a more recent UC Software version, be aware that enhancements to more recent software releases may not be backward compatible. Before downloading and installing more recent software, Poly strongly recommends that you read about changes to Poly software versions in the Poly UC Software 3.3.0 Administrators’ Guide..

Poly follows industry standard practices regarding support of software for discontinued End of Life (EOL) products. Poly supports software for the most current version and one previous major version OR two years after the release – whichever comes first. For reference, see the Poly End of Life (EOL) Support Policy..